guix-devel/gnu/packages/patches/icecat-CVE-2015-2713-pt2.patch

48 lines
1.9 KiB
Diff

From d84ed2990dd2304fef752213f1908280ff24d77c Mon Sep 17 00:00:00 2001
From: Mats Palmgren <mats@mozilla.com>
Date: Thu, 16 Apr 2015 09:04:19 +0000
Subject: [PATCH] Bug 1153478 - Part 2: Remove useless assertions. r=roc,
a=sledru
---
layout/generic/nsContainerFrame.cpp | 1 -
layout/generic/nsInlineFrame.cpp | 3 ---
2 files changed, 4 deletions(-)
diff --git a/layout/generic/nsContainerFrame.cpp b/layout/generic/nsContainerFrame.cpp
index 34878af..b95bddd 100644
--- a/layout/generic/nsContainerFrame.cpp
+++ b/layout/generic/nsContainerFrame.cpp
@@ -1516,7 +1516,6 @@ nsContainerFrame::DrainSelfOverflowList()
{
AutoFrameListPtr overflowFrames(PresContext(), StealOverflowFrames());
if (overflowFrames) {
- NS_ASSERTION(mFrames.NotEmpty(), "overflow list w/o frames");
mFrames.AppendFrames(nullptr, *overflowFrames);
return true;
}
diff --git a/layout/generic/nsInlineFrame.cpp b/layout/generic/nsInlineFrame.cpp
index a392a15..e0922bb 100644
--- a/layout/generic/nsInlineFrame.cpp
+++ b/layout/generic/nsInlineFrame.cpp
@@ -449,7 +449,6 @@ nsInlineFrame::DrainSelfOverflowListInternal(DrainFlags aFlags,
{
AutoFrameListPtr overflowFrames(PresContext(), StealOverflowFrames());
if (overflowFrames) {
- NS_ASSERTION(mFrames.NotEmpty(), "overflow list w/o frames");
// The frames on our own overflowlist may have been pushed by a
// previous lazilySetParentPointer Reflow so we need to ensure the
// correct parent pointer. This is sometimes skipped by Reflow.
@@ -1157,8 +1156,6 @@ nsFirstLineFrame::DrainSelfOverflowList()
{
AutoFrameListPtr overflowFrames(PresContext(), StealOverflowFrames());
if (overflowFrames) {
- NS_ASSERTION(mFrames.NotEmpty(), "overflow list w/o frames");
-
bool result = !overflowFrames->IsEmpty();
const nsFrameList::Slice& newFrames =
mFrames.AppendFrames(nullptr, *overflowFrames);
--
2.2.1