96 lines
3.1 KiB
Diff
96 lines
3.1 KiB
Diff
Combination of two patches that fix libopenshot tests when built with
|
|
system-provided ffmpeg and jsoncpp. See
|
|
|
|
https://github.com/OpenShot/libopenshot/pull/163
|
|
|
|
From 0d7691ab53433e1583f6a66ea96683b0f7af8a57 Mon Sep 17 00:00:00 2001
|
|
From: "FeRD (Frank Dana)" <ferdnyc@gmail.com>
|
|
Date: Mon, 17 Sep 2018 14:04:40 -0400
|
|
Subject: [PATCH] tests/CMakeFiles: Use FFMpeg like src/
|
|
|
|
---
|
|
tests/CMakeLists.txt | 32 +++++++++++++++++++++++++++++++-
|
|
1 file changed, 31 insertions(+), 1 deletion(-)
|
|
|
|
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
|
|
index 2c45550..4df8464 100644
|
|
--- a/tests/CMakeLists.txt
|
|
+++ b/tests/CMakeLists.txt
|
|
@@ -79,7 +79,37 @@ ENDIF (ImageMagick_FOUND)
|
|
FIND_PACKAGE(FFmpeg REQUIRED)
|
|
|
|
# Include FFmpeg headers (needed for compile)
|
|
-include_directories(${FFMPEG_INCLUDE_DIR})
|
|
+message('AVCODEC_FOUND: ${AVCODEC_FOUND}')
|
|
+message('AVCODEC_INCLUDE_DIRS: ${AVCODEC_INCLUDE_DIRS}')
|
|
+message('AVCODEC_LIBRARIES: ${AVCODEC_LIBRARIES}')
|
|
+
|
|
+IF (AVCODEC_FOUND)
|
|
+ include_directories(${AVCODEC_INCLUDE_DIRS})
|
|
+ENDIF (AVCODEC_FOUND)
|
|
+IF (AVDEVICE_FOUND)
|
|
+ include_directories(${AVDEVICE_INCLUDE_DIRS})
|
|
+ENDIF (AVDEVICE_FOUND)
|
|
+IF (AVFORMAT_FOUND)
|
|
+ include_directories(${AVFORMAT_INCLUDE_DIRS})
|
|
+ENDIF (AVFORMAT_FOUND)
|
|
+IF (AVFILTER_FOUND)
|
|
+ include_directories(${AVFILTER_INCLUDE_DIRS})
|
|
+ENDIF (AVFILTER_FOUND)
|
|
+IF (AVUTIL_FOUND)
|
|
+ include_directories(${AVUTIL_INCLUDE_DIRS})
|
|
+ENDIF (AVUTIL_FOUND)
|
|
+IF (POSTPROC_FOUND)
|
|
+ include_directories(${POSTPROC_INCLUDE_DIRS})
|
|
+ENDIF (POSTPROC_FOUND)
|
|
+IF (SWSCALE_FOUND)
|
|
+ include_directories(${SWSCALE_INCLUDE_DIRS})
|
|
+ENDIF (SWSCALE_FOUND)
|
|
+IF (SWRESAMPLE_FOUND)
|
|
+ include_directories(${SWRESAMPLE_INCLUDE_DIRS})
|
|
+ENDIF (SWRESAMPLE_FOUND)
|
|
+IF (AVRESAMPLE_FOUND)
|
|
+ include_directories(${AVRESAMPLE_INCLUDE_DIRS})
|
|
+ENDIF (AVRESAMPLE_FOUND)
|
|
|
|
################# LIBOPENSHOT-AUDIO ###################
|
|
# Find JUCE-based openshot Audio libraries
|
|
|
|
|
|
From e9e85cdfd036587adb86341f7f81619dc69f102c Mon Sep 17 00:00:00 2001
|
|
From: "FeRD (Frank Dana)" <ferdnyc@gmail.com>
|
|
Date: Mon, 17 Sep 2018 19:23:25 -0400
|
|
Subject: [PATCH] Use system jsoncpp in tests, too
|
|
|
|
The tests/ build needs to use the same jsoncpp as the src/ build,
|
|
or tests in Clip_Tests.cpp can fail.
|
|
---
|
|
tests/CMakeLists.txt | 10 ++++++++--
|
|
1 file changed, 8 insertions(+), 2 deletions(-)
|
|
|
|
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
|
|
index 4df8464..a1a0356 100644
|
|
--- a/tests/CMakeLists.txt
|
|
+++ b/tests/CMakeLists.txt
|
|
@@ -180,12 +180,18 @@ endif(OPENMP_FOUND)
|
|
# Find ZeroMQ library (used for socket communication & logging)
|
|
FIND_PACKAGE(ZMQ REQUIRED)
|
|
|
|
-# Include FFmpeg headers (needed for compile)
|
|
+# Include ZeroMQ headers (needed for compile)
|
|
include_directories(${ZMQ_INCLUDE_DIRS})
|
|
|
|
################### JSONCPP #####################
|
|
# Include jsoncpp headers (needed for JSON parsing)
|
|
-include_directories("../thirdparty/jsoncpp/include")
|
|
+if (USE_SYSTEM_JSONCPP)
|
|
+ find_package(JsonCpp REQUIRED)
|
|
+ include_directories(${JSONCPP_INCLUDE_DIRS})
|
|
+else()
|
|
+ message("Using embedded JsonCpp")
|
|
+ include_directories("../thirdparty/jsoncpp/include")
|
|
+endif(USE_SYSTEM_JSONCPP)
|
|
|
|
IF (NOT DISABLE_TESTS)
|
|
############### SET TEST SOURCE FILES #################
|