37 lines
1.3 KiB
Diff
37 lines
1.3 KiB
Diff
From 724194d7a9a91221a564579f64bdd6f0abd64219 Mon Sep 17 00:00:00 2001
|
|
From: Noah Mayr <max96at@gmail.com>
|
|
Date: Sun, 1 Mar 2015 10:10:56 +0100
|
|
Subject: [PATCH] Fixed deprecated libpng API usage.
|
|
|
|
---
|
|
src-IL/src/il_icon.c | 2 +-
|
|
src-IL/src/il_png.c | 4 ++--
|
|
2 files changed, 3 insertions(+), 3 deletions(-)
|
|
|
|
diff --git a/src-IL/src/il_icon.c b/src-IL/src/il_icon.c
|
|
index 2ccb1a3..fd9475d 100644
|
|
--- a/src-IL/src/il_icon.c
|
|
+++ b/src-IL/src/il_icon.c
|
|
@@ -525,7 +525,7 @@ ILboolean ico_readpng_get_image(ICOIMAGE *Icon, ILdouble display_exponent)
|
|
|
|
// Expand low-bit-depth grayscale images to 8 bits
|
|
if (ico_color_type == PNG_COLOR_TYPE_GRAY && bit_depth < 8) {
|
|
- png_set_gray_1_2_4_to_8(ico_png_ptr);
|
|
+ png_set_expand_gray_1_2_4_to_8(ico_png_ptr);
|
|
}
|
|
|
|
// Expand RGB images with transparency to full alpha channels
|
|
diff --git a/src-IL/src/il_png.c b/src-IL/src/il_png.c
|
|
index da9517d..2866508 100644
|
|
--- a/src-IL/src/il_png.c
|
|
+++ b/src-IL/src/il_png.c
|
|
@@ -277,7 +277,7 @@ ILboolean readpng_get_image(ILdouble display_exponent)
|
|
|
|
// Expand low-bit-depth grayscale images to 8 bits
|
|
if (png_color_type == PNG_COLOR_TYPE_GRAY && bit_depth < 8) {
|
|
- png_set_gray_1_2_4_to_8(png_ptr);
|
|
+ png_set_expand_gray_1_2_4_to_8(png_ptr);
|
|
}
|
|
|
|
// Expand RGB images with transparency to full alpha channels
|