37 lines
1.2 KiB
Diff
37 lines
1.2 KiB
Diff
Add $EUDEV_RULES_DIRECTORY to the list of rules directories.
|
|
|
|
The old udev 182 supported $UDEV_CONFIG_FILE, which in turn allowed
|
|
the search path to be customized, but eudev no longer has this, hence
|
|
this hack.
|
|
|
|
--- eudev-3.1.5/src/udev/udev-rules.c 2015-10-13 06:22:14.000000000 +0800
|
|
+++ eudev-3.1.5/src/udev/udev-rules.c 2015-10-16 20:45:38.491934336 +0800
|
|
@@ -47,15 +47,11 @@
|
|
};
|
|
};
|
|
|
|
-static const char* const rules_dirs[] = {
|
|
+static const char* rules_dirs[] = {
|
|
UDEV_CONF_DIR "/rules.d",
|
|
UDEV_RULES_DIR,
|
|
- UDEV_ROOT_RUN "/udev/rules.d",
|
|
UDEV_LIBEXEC_DIR "/rules.d",
|
|
-#ifdef HAVE_SPLIT_USR
|
|
- "/lib/udev/rules.d",
|
|
- "/usr/lib/udev/rules.d",
|
|
-#endif
|
|
+ NULL, /* placeholder for $EUDEV_RULES_DIRECTORY */
|
|
NULL};
|
|
|
|
struct udev_rules {
|
|
@@ -1704,6 +1700,9 @@
|
|
|
|
udev_rules_check_timestamp(rules);
|
|
|
|
+ /* Allow the user to specify an additional rules directory. */
|
|
+ rules_dirs[3] = getenv("EUDEV_RULES_DIRECTORY");
|
|
+
|
|
r = conf_files_list_strv(&files, ".rules", NULL, rules_dirs);
|
|
if (r < 0) {
|
|
log_error_errno(r, "failed to enumerate rules files: %m");
|