51 lines
1.5 KiB
Diff
51 lines
1.5 KiB
Diff
Fixes needed when avoiding bundled libraries.
|
|
|
|
--- icecat-45.3.0/xpcom/build/moz.build.orig
|
|
+++ icecat-45.3.0/xpcom/build/moz.build
|
|
@@ -92,10 +92,5 @@
|
|
'/docshell/base',
|
|
]
|
|
|
|
-if CONFIG['MOZ_VPX']:
|
|
- LOCAL_INCLUDES += [
|
|
- '/media/libvpx',
|
|
- ]
|
|
-
|
|
if CONFIG['MOZ_WIDGET_TOOLKIT'] == 'cocoa':
|
|
CXXFLAGS += CONFIG['TK_CFLAGS']
|
|
--- icecat-45.3.0/storage/moz.build.orig
|
|
+++ icecat-45.3.0/storage/moz.build
|
|
@@ -108,7 +108,6 @@
|
|
DEFINES['SQLITE_MAX_LIKE_PATTERN_LENGTH'] = 50000
|
|
|
|
LOCAL_INCLUDES += [
|
|
- '/db/sqlite3/src',
|
|
'/dom/base',
|
|
]
|
|
|
|
--- icecat-45.3.0/dom/indexedDB/moz.build.orig
|
|
+++ icecat-45.3.0/dom/indexedDB/moz.build
|
|
@@ -96,7 +96,6 @@
|
|
SOURCES['Key.cpp'].flags += ['-Wno-error=type-limits']
|
|
|
|
LOCAL_INCLUDES += [
|
|
- '/db/sqlite3/src',
|
|
'/dom/base',
|
|
'/dom/storage',
|
|
'/dom/workers',
|
|
--- icecat-45.3.0/modules/libmar/tests/Makefile.in.orig
|
|
+++ icecat-45.3.0/modules/libmar/tests/Makefile.in
|
|
@@ -10,12 +10,5 @@
|
|
ifndef MOZ_PROFILE_GENERATE
|
|
libs::
|
|
$(INSTALL) ../tool/signmar$(BIN_SUFFIX) $(TESTROOT)/unit
|
|
- $(INSTALL) $(DEPTH)/dist/bin/$(DLL_PREFIX)nss3$(DLL_SUFFIX) $(TESTROOT)/unit
|
|
-ifndef MOZ_FOLD_LIBS
|
|
- $(INSTALL) $(DEPTH)/dist/bin/$(DLL_PREFIX)nssutil3$(DLL_SUFFIX) $(TESTROOT)/unit
|
|
- $(INSTALL) $(DEPTH)/dist/bin/$(DLL_PREFIX)plc4$(DLL_SUFFIX) $(TESTROOT)/unit
|
|
- $(INSTALL) $(DEPTH)/dist/bin/$(DLL_PREFIX)nspr4$(DLL_SUFFIX) $(TESTROOT)/unit
|
|
- $(INSTALL) $(DEPTH)/dist/bin/$(DLL_PREFIX)plds4$(DLL_SUFFIX) $(TESTROOT)/unit
|
|
-endif
|
|
endif
|
|
endif # Not Android
|