36 lines
1.3 KiB
Diff
36 lines
1.3 KiB
Diff
This patch deactivates some tests that fail when ldc is built with the command:
|
|
|
|
./pre-inst-env guix environment guix --pure -- ./pre-inst-env guix build ldc@1.1.0-beta6
|
|
|
|
When the --keep-failed flag is added to the build command above, and the tests
|
|
run in the resulting /tmp/guix-build-ldc-1.1.0-beta6.drv-* directory, the tests
|
|
pass.
|
|
|
|
by Frederick M. Muriithi <fredmanglis@gmail.com>
|
|
|
|
diff --git a/d_do_test.d b/d_do_test.d
|
|
index aa67169..8173759 100755
|
|
--- a/d_do_test.d
|
|
+++ b/d_do_test.d
|
|
@@ -645,8 +645,6 @@ int main(string[] args)
|
|
auto gdb_output = execute(fThisRun, command, true, result_path);
|
|
if (testArgs.gdbMatch !is null)
|
|
{
|
|
- enforce(match(gdb_output, regex(testArgs.gdbMatch)),
|
|
- "\nGDB regex: '"~testArgs.gdbMatch~"' didn't match output:\n----\n"~gdb_output~"\n----\n");
|
|
}
|
|
}
|
|
}
|
|
diff --git a/runnable/gdb15729.sh b/runnable/gdb15729.sh
|
|
index 1d390e0..906b2b6 100755
|
|
--- a/runnable/gdb15729.sh
|
|
+++ b/runnable/gdb15729.sh
|
|
@@ -21,7 +21,6 @@ if [ $OS == "linux" ]; then
|
|
echo RESULT=
|
|
p s.val
|
|
EOF
|
|
- gdb ${dir}${SEP}gdb15729 --batch -x ${dir}${SEP}gdb15729.gdb | grep 'RESULT=.*1234' || exit 1
|
|
fi
|
|
|
|
rm -f ${libname} ${dir}${SEP}{gdb15729${OBJ},gdb15729${EXE},gdb15729.gdb}
|