81 lines
2.2 KiB
Diff
81 lines
2.2 KiB
Diff
This applies to Lua 5.2 and 5.3.
|
|
|
|
From 7a1b4e0829124976878ca2765a8e546667a92ceb Mon Sep 17 00:00:00 2001
|
|
From: Leo Famulari <leo@famulari.name>
|
|
Date: Fri, 30 Oct 2015 19:11:31 -0400
|
|
Subject: [PATCH] apply existing non-executable library patch and install
|
|
libraries as executable
|
|
|
|
---
|
|
Makefile | 6 +++---
|
|
src/Makefile | 8 +++++++-
|
|
2 files changed, 10 insertions(+), 4 deletions(-)
|
|
|
|
diff --git a/Makefile b/Makefile
|
|
index 1aea8e6..bfcfed9 100644
|
|
--- a/Makefile
|
|
+++ b/Makefile
|
|
@@ -44,7 +44,7 @@ INTERPRETER= lua
|
|
COMPILER= luac
|
|
TO_BIN= $(INTERPRETER) $(COMPILER)
|
|
TO_INC= lua.h luaconf.h lualib.h lauxlib.h lua.hpp
|
|
-TO_LIB= liblua.a
|
|
+TO_LIB= liblua.a liblua.so liblua.so.${V}
|
|
TO_PC= lua-$(V).pc
|
|
TO_MAN= lua.1 luac.1
|
|
|
|
@@ -56,7 +56,7 @@ R= $V.3
|
|
all: $(PLAT)
|
|
|
|
$(PLATS):
|
|
- cd src && $(MAKE) $@
|
|
+ cd src && $(MAKE) $@ V=$(V) R=$(R)
|
|
|
|
clean:
|
|
cd src && $(MAKE) $@
|
|
@@ -69,7 +69,7 @@ install: dummy $(TO_PC)
|
|
cd src && $(MKDIR) $(INSTALL_BIN) $(INSTALL_INC) $(INSTALL_LIB) $(INSTALL_PC) $(INSTALL_MAN) $(INSTALL_LMOD) $(INSTALL_CMOD)
|
|
cd src && $(INSTALL_EXEC) $(TO_BIN) $(INSTALL_BIN)
|
|
cd src && $(INSTALL_DATA) $(TO_INC) $(INSTALL_INC)
|
|
- cd src && $(INSTALL_DATA) $(TO_LIB) $(INSTALL_LIB)
|
|
+ cd src && $(INSTALL_EXEC) $(TO_LIB) $(INSTALL_LIB)
|
|
cd src && $(INSTALL_DATA) ../$(TO_PC) $(INSTALL_PC)
|
|
cd doc && $(INSTALL_DATA) $(TO_MAN) $(INSTALL_MAN)
|
|
|
|
diff --git a/src/Makefile b/src/Makefile
|
|
index 7b4b2b7..c86476e 100644
|
|
--- a/src/Makefile
|
|
+++ b/src/Makefile
|
|
@@ -29,6 +29,7 @@ MYOBJS=
|
|
PLATS= aix ansi bsd freebsd generic linux macosx mingw posix solaris
|
|
|
|
LUA_A= liblua.a
|
|
+LUA_SO= liblua.so
|
|
CORE_O= lapi.o lcode.o lctype.o ldebug.o ldo.o ldump.o lfunc.o lgc.o llex.o \
|
|
lmem.o lobject.o lopcodes.o lparser.o lstate.o lstring.o ltable.o \
|
|
ltm.o lundump.o lvm.o lzio.o
|
|
@@ -43,7 +44,7 @@ LUAC_T= luac
|
|
LUAC_O= luac.o
|
|
|
|
ALL_O= $(BASE_O) $(LUA_O) $(LUAC_O)
|
|
-ALL_T= $(LUA_A) $(LUA_T) $(LUAC_T)
|
|
+ALL_T= $(LUA_A) $(LUA_T) $(LUAC_T) $(LUA_SO)
|
|
ALL_A= $(LUA_A)
|
|
|
|
# Targets start here.
|
|
@@ -55,6 +56,11 @@ o: $(ALL_O)
|
|
|
|
a: $(ALL_A)
|
|
|
|
+$(LUA_SO): $(CORE_O) $(LIB_O)
|
|
+ $(CC) -shared -ldl -Wl,-soname,$(LUA_SO).$(V) -o $@.$(R) $? -lm $(MYLDFLAGS)
|
|
+ ln -sf $(LUA_SO).$(R) $(LUA_SO).$(V)
|
|
+ ln -sf $(LUA_SO).$(R) $(LUA_SO)
|
|
+
|
|
$(LUA_A): $(BASE_O)
|
|
$(AR) $@ $(BASE_O)
|
|
$(RANLIB) $@
|
|
--
|
|
2.6.1
|
|
|