18 lines
668 B
Diff
18 lines
668 B
Diff
This patch removes the explicit reference to the 'perl' binary,
|
|
such that OpenSSL does not retain a reference to Perl.
|
|
|
|
The 'c_rehash' program is seldom used, but it is used nonetheless
|
|
to create symbolic links to certificates, for instance in the 'nss-certs'
|
|
package.
|
|
|
|
--- openssl-1.0.2g/tools/c_rehash.in 2015-09-09 18:36:07.313316482 +0200
|
|
+++ openssl-1.0.2g/tools/c_rehash.in 2015-09-09 18:36:28.965458458 +0200
|
|
@@ -1,4 +1,6 @@
|
|
-#!/usr/local/bin/perl
|
|
+eval '(exit $?0)' && eval 'exec perl -wS "$0" ${1+"$@"}'
|
|
+ & eval 'exec perl -wS "$0" $argv:q'
|
|
+ if 0;
|
|
|
|
# Perl c_rehash script, scan all files in a directory
|
|
# and add symbolic links to their hash values.
|