49 lines
1.7 KiB
Diff
49 lines
1.7 KiB
Diff
Fix CVE-2017-11335:
|
|
|
|
http://bugzilla.maptools.org/show_bug.cgi?id=2715
|
|
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-11335
|
|
|
|
Patch copied from upstream source repository:
|
|
|
|
https://gitlab.com/libtiff/libtiff/commit/979751c407648bd29a6bdf5581ab9e3af42c1223
|
|
|
|
From 979751c407648bd29a6bdf5581ab9e3af42c1223 Mon Sep 17 00:00:00 2001
|
|
From: Even Rouault <even.rouault@spatialys.com>
|
|
Date: Sat, 15 Jul 2017 11:13:46 +0000
|
|
Subject: [PATCH] * tools/tiff2pdf.c: prevent heap buffer overflow write in
|
|
"Raw" mode on PlanarConfig=Contig input images. Fixes
|
|
http://bugzilla.maptools.org/show_bug.cgi?id=2715 Reported by team OWL337
|
|
|
|
---
|
|
ChangeLog | 7 +++++++
|
|
tools/tiff2pdf.c | 9 +++++++--
|
|
2 files changed, 14 insertions(+), 2 deletions(-)
|
|
|
|
diff --git a/tools/tiff2pdf.c b/tools/tiff2pdf.c
|
|
index 8e4e24ef..caf64ee5 100644
|
|
--- a/tools/tiff2pdf.c
|
|
+++ b/tools/tiff2pdf.c
|
|
@@ -1,4 +1,4 @@
|
|
-/* $Id: tiff2pdf.c,v 1.101 2016-12-20 17:28:17 erouault Exp $
|
|
+/* $Id: tiff2pdf.c,v 1.102 2017-07-15 11:13:46 erouault Exp $
|
|
*
|
|
* tiff2pdf - converts a TIFF image to a PDF document
|
|
*
|
|
@@ -1737,7 +1737,12 @@ void t2p_read_tiff_data(T2P* t2p, TIFF* input){
|
|
return;
|
|
|
|
t2p->pdf_transcode = T2P_TRANSCODE_ENCODE;
|
|
- if(t2p->pdf_nopassthrough==0){
|
|
+ /* It seems that T2P_TRANSCODE_RAW mode doesn't support separate->contig */
|
|
+ /* conversion. At least t2p_read_tiff_size and t2p_read_tiff_size_tile */
|
|
+ /* do not take into account the number of samples, and thus */
|
|
+ /* that can cause heap buffer overflows such as in */
|
|
+ /* http://bugzilla.maptools.org/show_bug.cgi?id=2715 */
|
|
+ if(t2p->pdf_nopassthrough==0 && t2p->tiff_planar!=PLANARCONFIG_SEPARATE){
|
|
#ifdef CCITT_SUPPORT
|
|
if(t2p->tiff_compression==COMPRESSION_CCITTFAX4
|
|
){
|
|
--
|
|
2.16.1
|
|
|