44 lines
1.3 KiB
Diff
44 lines
1.3 KiB
Diff
Fixes CVE-2019-6778:
|
|
|
|
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-6778
|
|
|
|
Patch copied from upstream source repository:
|
|
|
|
https://git.qemu.org/?p=qemu.git;a=commitdiff;h=a7104eda7dab99d0cdbd3595c211864cba415905
|
|
|
|
From a7104eda7dab99d0cdbd3595c211864cba415905 Mon Sep 17 00:00:00 2001
|
|
From: Prasad J Pandit <pjp@fedoraproject.org>
|
|
Date: Sun, 13 Jan 2019 23:29:48 +0530
|
|
Subject: [PATCH] slirp: check data length while emulating ident function
|
|
|
|
While emulating identification protocol, tcp_emu() does not check
|
|
available space in the 'sc_rcv->sb_data' buffer. It could lead to
|
|
heap buffer overflow issue. Add check to avoid it.
|
|
|
|
Reported-by: Kira <864786842@qq.com>
|
|
Signed-off-by: Prasad J Pandit <pjp@fedoraproject.org>
|
|
Signed-off-by: Samuel Thibault <samuel.thibault@ens-lyon.org>
|
|
---
|
|
slirp/tcp_subr.c | 5 +++++
|
|
1 file changed, 5 insertions(+)
|
|
|
|
diff --git a/slirp/tcp_subr.c b/slirp/tcp_subr.c
|
|
index 4a9a5b5edc..23a841f26e 100644
|
|
--- a/slirp/tcp_subr.c
|
|
+++ b/slirp/tcp_subr.c
|
|
@@ -634,6 +634,11 @@ tcp_emu(struct socket *so, struct mbuf *m)
|
|
socklen_t addrlen = sizeof(struct sockaddr_in);
|
|
struct sbuf *so_rcv = &so->so_rcv;
|
|
|
|
+ if (m->m_len > so_rcv->sb_datalen
|
|
+ - (so_rcv->sb_wptr - so_rcv->sb_data)) {
|
|
+ return 1;
|
|
+ }
|
|
+
|
|
memcpy(so_rcv->sb_wptr, m->m_data, m->m_len);
|
|
so_rcv->sb_wptr += m->m_len;
|
|
so_rcv->sb_rptr += m->m_len;
|
|
--
|
|
2.20.1
|
|
|