30 lines
1.4 KiB
Diff
30 lines
1.4 KiB
Diff
Index: vorbis-tools/oggenc/oggenc.c
|
|
===================================================================
|
|
--- vorbis-tools/oggenc/oggenc.c (revision 19116)
|
|
+++ vorbis-tools/oggenc/oggenc.c (revision 19117)
|
|
@@ -98,4 +98,6 @@
|
|
0,0,0.f,
|
|
0, 0, 0, 0, 0};
|
|
+ input_format raw_format = {NULL, 0, raw_open, wav_close, "raw",
|
|
+ N_("RAW file reader")};
|
|
|
|
int i;
|
|
@@ -240,6 +242,4 @@
|
|
if(opt.rawmode)
|
|
{
|
|
- input_format raw_format = {NULL, 0, raw_open, wav_close, "raw",
|
|
- N_("RAW file reader")};
|
|
|
|
enc_opts.rate=opt.raw_samplerate;
|
|
Index: vorbis-tools/oggenc/skeleton.h
|
|
===================================================================
|
|
--- vorbis-tools/oggenc/skeleton.h (revision 19116)
|
|
+++ vorbis-tools/oggenc/skeleton.h (revision 19117)
|
|
@@ -42,5 +42,5 @@
|
|
ogg_int64_t start_granule; /* start granule value */
|
|
ogg_uint32_t preroll; /* preroll */
|
|
- unsigned char granule_shift; // a 8-bit field /* 1 byte value holding the granule shift */
|
|
+ unsigned char granule_shift; /* 1 byte value holding the granule shift */
|
|
char *message_header_fields; /* holds all the message header fields */
|
|
/* current total size of the message header fields, for realloc purpose, initially zero */
|