33 lines
717 B
Diff
33 lines
717 B
Diff
See https://bugzilla.gnome.org/show_bug.cgi?id=706462
|
|
|
|
Subject: [PATCH] Make grammar.y work with Bison 3
|
|
|
|
YYLEX_PARAM is no longer supported in Bison 3.
|
|
---
|
|
gst/parse/grammar.y | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/gst/parse/grammar.y b/gst/parse/grammar.y
|
|
index 8a9019c..f533389 100644
|
|
--- a/gst/parse/grammar.y
|
|
+++ b/gst/parse/grammar.y
|
|
@@ -26,7 +26,6 @@
|
|
*/
|
|
|
|
#define YYERROR_VERBOSE 1
|
|
-#define YYLEX_PARAM scanner
|
|
|
|
#define YYENABLE_NLS 0
|
|
|
|
@@ -659,6 +658,7 @@ static int yyerror (void *scanner, graph_t *graph, const char *s);
|
|
%right '.'
|
|
%left '!' '='
|
|
|
|
+%lex-param { void *scanner }
|
|
%parse-param { void *scanner }
|
|
%parse-param { graph_t *graph }
|
|
%pure-parser
|
|
--
|
|
1.8.3.4
|
|
|