54 lines
1.7 KiB
Diff
54 lines
1.7 KiB
Diff
Fix CVE-2016-10093:
|
|
|
|
http://bugzilla.maptools.org/show_bug.cgi?id=2610
|
|
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2016-10093
|
|
https://security-tracker.debian.org/tracker/CVE-2016-10093
|
|
|
|
2016-12-03 Even Rouault <even.rouault at spatialys.com>
|
|
|
|
* tools/tiffcp.c: fix uint32 underflow/overflow that can cause
|
|
heap-based buffer overflow.
|
|
Reported by Agostino Sarubbo.
|
|
Fixes http://bugzilla.maptools.org/show_bug.cgi?id=2610
|
|
|
|
/cvs/maptools/cvsroot/libtiff/ChangeLog,v <-- ChangeLog
|
|
new revision: 1.1187; previous revision: 1.1186
|
|
/cvs/maptools/cvsroot/libtiff/tools/tiffcp.c,v <-- tools/tiffcp.c
|
|
new revision: 1.59; previous revision: 1.58
|
|
|
|
Index: libtiff/tools/tiffcp.c
|
|
===================================================================
|
|
RCS file: /cvs/maptools/cvsroot/libtiff/tools/tiffcp.c,v
|
|
retrieving revision 1.58
|
|
retrieving revision 1.59
|
|
diff -u -r1.58 -r1.59
|
|
--- libtiff/tools/tiffcp.c 3 Dec 2016 15:44:15 -0000 1.58
|
|
+++ libtiff/tools/tiffcp.c 3 Dec 2016 16:40:01 -0000 1.59
|
|
@@ -1163,7 +1163,7 @@
|
|
|
|
static void
|
|
cpStripToTile(uint8* out, uint8* in,
|
|
- uint32 rows, uint32 cols, int outskew, int inskew)
|
|
+ uint32 rows, uint32 cols, int outskew, int64 inskew)
|
|
{
|
|
while (rows-- > 0) {
|
|
uint32 j = cols;
|
|
@@ -1320,7 +1320,7 @@
|
|
tdata_t tilebuf;
|
|
uint32 imagew = TIFFScanlineSize(in);
|
|
uint32 tilew = TIFFTileRowSize(in);
|
|
- int iskew = imagew - tilew;
|
|
+ int64 iskew = (int64)imagew - (int64)tilew;
|
|
uint8* bufp = (uint8*) buf;
|
|
uint32 tw, tl;
|
|
uint32 row;
|
|
@@ -1348,7 +1348,7 @@
|
|
status = 0;
|
|
goto done;
|
|
}
|
|
- if (colb + tilew > imagew) {
|
|
+ if (colb > iskew) {
|
|
uint32 width = imagew - colb;
|
|
uint32 oskew = tilew - width;
|
|
cpStripToTile(bufp + colb,
|