22 lines
656 B
Diff
22 lines
656 B
Diff
Copied from Fedora.
|
|
|
|
http://pkgs.fedoraproject.org/cgit/libwmf.git/tree/libwmf-0.2.8.4-CAN-2004-0941.patch
|
|
|
|
--- libwmf-0.2.8.4/src/extra/gd/gd_png.c 2004-11-11 14:02:37.407589824 -0500
|
|
+++ libwmf-0.2.8.4/src/extra/gd/gd_png.c 2004-11-11 14:04:29.672522960 -0500
|
|
@@ -188,6 +188,14 @@
|
|
|
|
png_get_IHDR (png_ptr, info_ptr, &width, &height, &bit_depth, &color_type,
|
|
&interlace_type, NULL, NULL);
|
|
+ if (overflow2(sizeof (int), width))
|
|
+ {
|
|
+ return NULL;
|
|
+ }
|
|
+ if (overflow2(sizeof (int) * width, height))
|
|
+ {
|
|
+ return NULL;
|
|
+ }
|
|
if ((color_type == PNG_COLOR_TYPE_RGB) ||
|
|
(color_type == PNG_COLOR_TYPE_RGB_ALPHA))
|
|
{
|