22 lines
862 B
Diff
22 lines
862 B
Diff
Patch adapted from <http://git.yoctoproject.org/cgit.cgi/poky/plain/meta/recipes-core/coreutils/coreutils-8.22/fix-for-dummy-man-usage.patch>.
|
|
|
|
Fix for 'dummy-man' usage, when cross-compiling.
|
|
|
|
The options should be before the final argument, otherwise, the following error
|
|
would appear when compiling:
|
|
|
|
dummy-man: too many non-option arguments
|
|
|
|
--- coreutils-8.23/Makefile.in 2014-07-18 18:22:24.000000000 -0400
|
|
+++ coreutils-8.23/Makefile.in 2014-08-03 20:21:10.849158313 -0400
|
|
@@ -14076,8 +14076,8 @@
|
|
&& $(run_help2man) \
|
|
--source='$(PACKAGE_STRING)' \
|
|
--include=$(srcdir)/man/$$name.x \
|
|
- --output=$$t/$$name.1 $$t/$$argv \
|
|
--info-page='coreutils \(aq'$$name' invocation\(aq' \
|
|
+ --output=$$t/$$name.1 $$t/$$argv \
|
|
&& sed \
|
|
-e 's|$*\.td/||g' \
|
|
-e '/For complete documentation/d' \
|