18 lines
847 B
Diff
18 lines
847 B
Diff
Fix test compilation with exa.h in configure when using glibc 2.20.
|
|
Inspired by a patch by Peter Hutterer <peter.hutterer@who-t.net>.
|
|
See <https://raw.githubusercontent.com/openembedded/oe-core/master/meta/recipes-graphics/xorg-driver/xf86-input-synaptics/always_include_xorg_server.h.patch>.
|
|
|
|
--- xf86-video-r128-6.9.2/configure.~1~ 2013-10-02 14:38:15.000000000 -0400
|
|
+++ xf86-video-r128-6.9.2/configure 2014-12-19 01:23:03.346735159 -0500
|
|
@@ -18400,7 +18400,9 @@
|
|
|
|
SAVE_CPPFLAGS="$CPPFLAGS"
|
|
CPPFLAGS="$CPPFLAGS $XORG_CFLAGS"
|
|
- ac_fn_c_check_header_mongrel "$LINENO" "exa.h" "ac_cv_header_exa_h" "$ac_includes_default"
|
|
+ ac_fn_c_check_header_mongrel "$LINENO" "exa.h" "ac_cv_header_exa_h" "$ac_includes_default
|
|
+#include <xorg-server.h>
|
|
+"
|
|
if test "x$ac_cv_header_exa_h" = xyes; then :
|
|
have_exa_h="yes"
|
|
else
|