guix-devel/gnu/packages/patches/python-django-fix-testcase....

43 lines
2.0 KiB
Diff
Raw Blame History

This file contains invisible Unicode characters!

This file contains invisible Unicode characters that may be processed differently from what appears below. If your use case is intentional and legitimate, you can safely ignore this warning. Use the Escape button to reveal hidden characters.

From 24123c31362b5f3783d84d133c160e9fe16805fe Mon Sep 17 00:00:00 2001
From: Tim Graham <timograham@gmail.com>
Date: Mon, 1 Aug 2016 15:40:46 -0400
Subject: [PATCH] Fixed admin_utils test failures due to translation updates.
https://github.com/django/django/commit/24123c31362b5f3783d84d133c160e9fe16805fe
---
tests/admin_utils/test_logentry.py | 7 ++++---
1 file changed, 4 insertions(+), 3 deletions(-)
diff --git a/tests/admin_utils/test_logentry.py b/tests/admin_utils/test_logentry.py
index 7798373..8259bf0 100644
--- a/tests/admin_utils/test_logentry.py
+++ b/tests/admin_utils/test_logentry.py
@@ -59,7 +59,7 @@ class LogEntryTests(TestCase):
logentry = LogEntry.objects.filter(content_type__model__iexact='article').latest('id')
self.assertEqual(logentry.get_change_message(), 'Changed title and hist.')
with translation.override('fr'):
- self.assertEqual(logentry.get_change_message(), 'Modification de title et hist.')
+ self.assertEqual(logentry.get_change_message(), 'Title et hist modifié(s).')
add_url = reverse('admin:admin_utils_article_add')
post_data['title'] = 'New'
@@ -117,11 +117,12 @@ class LogEntryTests(TestCase):
'Changed domain. Added article "Article object". '
'Changed title for article "Article object". Deleted article "Article object".'
)
+
with translation.override('fr'):
self.assertEqual(
logentry.get_change_message(),
- 'Modification de domain. Article « Article object » ajouté. '
- 'Modification de title pour l\'objet article « Article object ». Article « Article object » supprimé.'
+ "Domain modifié(s). Article « Article object » ajouté. "
+ "Title modifié(s) pour l'objet article « Article object ». Article « Article object » supprimé."
)
def test_logentry_get_edited_object(self):
--
2.7.4