14 lines
603 B
Diff
14 lines
603 B
Diff
Skeleton status files are installed read-only. When copying to the config dir
|
|
upon initialization, make sure they end up writable.
|
|
|
|
--- byobu-5.98/usr/bin/byobu-janitor.in
|
|
+++ byobu-5.98/usr/bin/byobu-janitor.in
|
|
@@ -82,6 +82,7 @@
|
|
if [ ! -r "$BYOBU_CONFIG_DIR/$f" ]; then
|
|
# Copy from skeleton, if possible
|
|
cp -f "$BYOBU_PREFIX/share/$PKG/status/$f" "$BYOBU_CONFIG_DIR/$f"
|
|
+ chmod +w "$BYOBU_CONFIG_DIR/$f"
|
|
# Enable ec2_cost, if we're in ec2 and seeding a new setup
|
|
if metadata_available; then
|
|
$BYOBU_SED_INLINE -e "s/#ec2_cost/ec2_cost/g" "$($BYOBU_READLINK -f $BYOBU_CONFIG_DIR/$f)"
|