132 lines
4.9 KiB
Diff
132 lines
4.9 KiB
Diff
Fix heap-based buffer overflow in _TIFFmemcpy():
|
|
|
|
http://bugzilla.maptools.org/show_bug.cgi?id=2604
|
|
|
|
2016-12-03 Even Rouault <even.rouault at spatialys.com>
|
|
|
|
* libtiff/tif_pixarlog.c, libtiff/tif_luv.c: fix heap-based buffer
|
|
overflow on generation of PixarLog / LUV compressed files, with
|
|
ColorMap, TransferFunction attached and nasty plays with bitspersample.
|
|
The fix for LUV has not been tested, but suffers from the same kind
|
|
of issue of PixarLog.
|
|
Reported by Agostino Sarubbo.
|
|
Fixes http://bugzilla.maptools.org/show_bug.cgi?id=2604
|
|
|
|
/cvs/maptools/cvsroot/libtiff/ChangeLog,v <-- ChangeLog
|
|
new revision: 1.1175; previous revision: 1.1174
|
|
/cvs/maptools/cvsroot/libtiff/libtiff/tif_luv.c,v <-- libtiff/tif_luv.c
|
|
new revision: 1.44; previous revision: 1.43
|
|
/cvs/maptools/cvsroot/libtiff/libtiff/tif_pixarlog.c,v <--
|
|
libtiff/tif_pixarlog.c
|
|
new revision: 1.49; previous revision: 1.48
|
|
|
|
Index: libtiff/libtiff/tif_luv.c
|
|
===================================================================
|
|
RCS file: /cvs/maptools/cvsroot/libtiff/libtiff/tif_luv.c,v
|
|
retrieving revision 1.43
|
|
retrieving revision 1.44
|
|
diff -u -r1.43 -r1.44
|
|
--- libtiff/libtiff/tif_luv.c 4 Sep 2016 21:32:56 -0000 1.43
|
|
+++ libtiff/libtiff/tif_luv.c 2 Dec 2016 23:05:51 -0000 1.44
|
|
@@ -1,4 +1,4 @@
|
|
-/* $Id: tif_luv.c,v 1.43 2016-09-04 21:32:56 erouault Exp $ */
|
|
+/* $Id: tif_luv.c,v 1.44 2016-12-02 23:05:51 erouault Exp $ */
|
|
|
|
/*
|
|
* Copyright (c) 1997 Greg Ward Larson
|
|
@@ -158,6 +158,7 @@
|
|
typedef struct logLuvState LogLuvState;
|
|
|
|
struct logLuvState {
|
|
+ int encoder_state; /* 1 if encoder correctly initialized */
|
|
int user_datafmt; /* user data format */
|
|
int encode_meth; /* encoding method */
|
|
int pixel_size; /* bytes per pixel */
|
|
@@ -1552,6 +1553,7 @@
|
|
td->td_photometric, "must be either LogLUV or LogL");
|
|
break;
|
|
}
|
|
+ sp->encoder_state = 1;
|
|
return (1);
|
|
notsupported:
|
|
TIFFErrorExt(tif->tif_clientdata, module,
|
|
@@ -1563,19 +1565,27 @@
|
|
static void
|
|
LogLuvClose(TIFF* tif)
|
|
{
|
|
+ LogLuvState* sp = (LogLuvState*) tif->tif_data;
|
|
TIFFDirectory *td = &tif->tif_dir;
|
|
|
|
+ assert(sp != 0);
|
|
/*
|
|
* For consistency, we always want to write out the same
|
|
* bitspersample and sampleformat for our TIFF file,
|
|
* regardless of the data format being used by the application.
|
|
* Since this routine is called after tags have been set but
|
|
* before they have been recorded in the file, we reset them here.
|
|
+ * Note: this is really a nasty approach. See PixarLogClose
|
|
*/
|
|
- td->td_samplesperpixel =
|
|
- (td->td_photometric == PHOTOMETRIC_LOGL) ? 1 : 3;
|
|
- td->td_bitspersample = 16;
|
|
- td->td_sampleformat = SAMPLEFORMAT_INT;
|
|
+ if( sp->encoder_state )
|
|
+ {
|
|
+ /* See PixarLogClose. Might avoid issues with tags whose size depends
|
|
+ * on those below, but not completely sure this is enough. */
|
|
+ td->td_samplesperpixel =
|
|
+ (td->td_photometric == PHOTOMETRIC_LOGL) ? 1 : 3;
|
|
+ td->td_bitspersample = 16;
|
|
+ td->td_sampleformat = SAMPLEFORMAT_INT;
|
|
+ }
|
|
}
|
|
|
|
static void
|
|
Index: libtiff/libtiff/tif_pixarlog.c
|
|
===================================================================
|
|
RCS file: /cvs/maptools/cvsroot/libtiff/libtiff/tif_pixarlog.c,v
|
|
retrieving revision 1.48
|
|
retrieving revision 1.49
|
|
diff -u -r1.48 -r1.49
|
|
--- libtiff/libtiff/tif_pixarlog.c 23 Sep 2016 22:12:18 -0000 1.48
|
|
+++ libtiff/libtiff/tif_pixarlog.c 2 Dec 2016 23:05:51 -0000 1.49
|
|
@@ -1,4 +1,4 @@
|
|
-/* $Id: tif_pixarlog.c,v 1.48 2016-09-23 22:12:18 erouault Exp $ */
|
|
+/* $Id: tif_pixarlog.c,v 1.49 2016-12-02 23:05:51 erouault Exp $ */
|
|
|
|
/*
|
|
* Copyright (c) 1996-1997 Sam Leffler
|
|
@@ -1233,8 +1233,10 @@
|
|
static void
|
|
PixarLogClose(TIFF* tif)
|
|
{
|
|
+ PixarLogState* sp = (PixarLogState*) tif->tif_data;
|
|
TIFFDirectory *td = &tif->tif_dir;
|
|
|
|
+ assert(sp != 0);
|
|
/* In a really sneaky (and really incorrect, and untruthful, and
|
|
* troublesome, and error-prone) maneuver that completely goes against
|
|
* the spirit of TIFF, and breaks TIFF, on close, we covertly
|
|
@@ -1243,8 +1245,19 @@
|
|
* readers that don't know about PixarLog, or how to set
|
|
* the PIXARLOGDATFMT pseudo-tag.
|
|
*/
|
|
- td->td_bitspersample = 8;
|
|
- td->td_sampleformat = SAMPLEFORMAT_UINT;
|
|
+
|
|
+ if (sp->state&PLSTATE_INIT) {
|
|
+ /* We test the state to avoid an issue such as in
|
|
+ * http://bugzilla.maptools.org/show_bug.cgi?id=2604
|
|
+ * What appends in that case is that the bitspersample is 1 and
|
|
+ * a TransferFunction is set. The size of the TransferFunction
|
|
+ * depends on 1<<bitspersample. So if we increase it, an access
|
|
+ * out of the buffer will happen at directory flushing.
|
|
+ * Another option would be to clear those targs.
|
|
+ */
|
|
+ td->td_bitspersample = 8;
|
|
+ td->td_sampleformat = SAMPLEFORMAT_UINT;
|
|
+ }
|
|
}
|
|
|
|
static void
|