16 lines
396 B
Diff
16 lines
396 B
Diff
Copied from Fedora.
|
|
|
|
http://pkgs.fedoraproject.org/cgit/libwmf.git/tree/libwmf-0.2.8.4-CVE-2007-0455.patch
|
|
|
|
--- libwmf-0.2.8.4/src/extra/gd/gdft.c 2010-12-06 11:18:26.000000000 +0000
|
|
+++ libwmf-0.2.8.4/src/extra/gd/gdft.c 2010-12-06 11:21:09.000000000 +0000
|
|
@@ -811,7 +811,7 @@
|
|
{
|
|
ch = c & 0xFF; /* don't extend sign */
|
|
}
|
|
- next++;
|
|
+ if (*next) next++;
|
|
}
|
|
else
|
|
{
|