36 lines
1.1 KiB
Diff
36 lines
1.1 KiB
Diff
Copied from Debian.
|
|
|
|
From: Petr Stodulka <pstodulk@redhat.com>
|
|
Date: Mon, 14 Sep 2015 18:23:17 +0200
|
|
Subject: Upstream fix for heap overflow
|
|
Bug-Debian: https://bugs.debian.org/802162
|
|
Bug-RedHat: https://bugzilla.redhat.com/show_bug.cgi?id=1260944
|
|
Origin: https://bugzilla.redhat.com/attachment.cgi?id=1073002
|
|
Forwarded: yes
|
|
|
|
---
|
|
crypt.c | 12 +++++++++++-
|
|
1 file changed, 11 insertions(+), 1 deletion(-)
|
|
|
|
--- a/crypt.c
|
|
+++ b/crypt.c
|
|
@@ -465,7 +465,17 @@
|
|
GLOBAL(pInfo->encrypted) = FALSE;
|
|
defer_leftover_input(__G);
|
|
for (n = 0; n < RAND_HEAD_LEN; n++) {
|
|
- b = NEXTBYTE;
|
|
+ /* 2012-11-23 SMS. (OUSPG report.)
|
|
+ * Quit early if compressed size < HEAD_LEN. The resulting
|
|
+ * error message ("unable to get password") could be improved,
|
|
+ * but it's better than trying to read nonexistent data, and
|
|
+ * then continuing with a negative G.csize. (See
|
|
+ * fileio.c:readbyte()).
|
|
+ */
|
|
+ if ((b = NEXTBYTE) == (ush)EOF)
|
|
+ {
|
|
+ return PK_ERR;
|
|
+ }
|
|
h[n] = (uch)b;
|
|
Trace((stdout, " (%02x)", h[n]));
|
|
}
|