guix-devel/gnu/packages/patches/xapian-revert-5489fb2f8.patch

24 lines
833 B
Diff

Revert this upstream commit which breaks a test case in "notmuch":
https://git.xapian.org/?p=xapian;a=commitdiff;h=5489fb2f838c0f0b0a593b4c17df282a93a1fe5a
See the notmuch FAQ entry:
https://notmuchmail.org/faq/#index12h2
This should be fixed for later releases.
diff --git a/backends/glass/glass_postlist.cc b/xapian-core/backends/glass/glass_postlist.cc
index 80e578b85..a47f14a68 100644
--- a/backends/glass/glass_postlist.cc
+++ b/backends/glass/glass_postlist.cc
@@ -759,7 +759,7 @@ GlassPostList::open_nearby_postlist(const std::string & term_,
(void)need_pos;
if (term_.empty())
RETURN(NULL);
- if (!this_db.get() || this_db->postlist_table.is_modified())
+ if (!this_db.get() || this_db->postlist_table.is_writable())
RETURN(NULL);
RETURN(new GlassPostList(this_db, term_, cursor->clone()));
}