guix-devel/gnu/packages/patches/fontforge-svg-modtime.patch

36 lines
1.2 KiB
Diff

Propagate source font modification time to svg during conversion. Similar to
what upstream commit 95a470e941d9a20fbdaca51334e8b6b9d93cfae4 did for TTF
files.
Submitted upstream at http://github.com/fontforge/fontforge/pull/2696
--- a/fontforge/svg.c
+++ b/fontforge/svg.c
@@ -27,7 +27,6 @@
#include "fontforgevw.h"
#include <unistd.h>
#include <math.h>
-#include <time.h>
#include <locale.h>
#include <utype.h>
#include <chardata.h>
@@ -62,7 +61,6 @@ static int svg_outfontheader(FILE *file, SplineFont *sf,int layer) {
BlueData bd;
char *hash, *hasv, ch;
int minu, maxu, i;
- time_t now;
const char *author = GetAuthor();
memset(&info,0,sizeof(info));
@@ -78,9 +76,8 @@ static int svg_outfontheader(FILE *file, SplineFont *sf,int layer) {
fprintf( file, "\n-->\n" );
}
fprintf( file, "<svg xmlns=\"http://www.w3.org/2000/svg\" xmlns:xlink=\"http://www.w3.org/1999/xlink\" version=\"1.1\">\n" );
- time(&now);
fprintf( file, "<metadata>\nCreated by FontForge %d at %s",
- FONTFORGE_VERSIONDATE_RAW, ctime(&now) );
+ FONTFORGE_VERSIONDATE_RAW, ctime((time_t*)&sf->modificationtime) );
if ( author!=NULL )
fprintf(file," By %s\n", author);
else