guix-devel/gnu/packages/patches/hmmer-remove-cpu-specificit...

23 lines
953 B
Diff

This patch removes compilation flags which make the build for the machine
where compilation takes place, rendering the build not reproducible.
diff --git a/configure b/configure
index 8b6aaef..49a6afc 100755
--- a/configure
+++ b/configure
@@ -6125,14 +6125,6 @@ fi # guess arch
if test "x$ax_gcc_arch" != x -a "x$ax_gcc_arch" != xno; then
for arch in $ax_gcc_arch; do
- if test "x$acx_maxopt_portable" = xyes; then # if we require portable code
- flags="-mtune=$arch"
- # -mcpu=$arch and m$arch generate nonportable code on every arch except
- # x86. And some other arches (e.g. Alpha) don't accept -mtune. Grrr.
- case $host_cpu in i*86|x86_64*) flags="$flags -mcpu=$arch -m$arch";; esac
- else
- flags="-march=$arch -mcpu=$arch -m$arch"
- fi
for flag in $flags; do
as_CACHEVAR=`$as_echo "ax_cv_check_cflags__$flag" | $as_tr_sh`
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking whether C compiler accepts $flag" >&5