guix-devel/gnu/packages/patches/ledger-revert-boost-python-...

40 lines
1.3 KiB
Diff

From 01220484f428a447e9b00e071a0d85185f30e1de Mon Sep 17 00:00:00 2001
From: Alexis Hildebrandt <afh@surryhill.net>
Date: Wed, 22 Jun 2016 15:43:37 +0200
Subject: [PATCH] Revert "[python] Add fix for Boost.Python compile errors"
This reverts commit 11590e134eafa768ccc4a171cc7fb216e906095f.
---
src/py_commodity.cc | 3 ---
src/py_journal.cc | 3 ---
2 files changed, 6 deletions(-)
diff --git a/src/py_commodity.cc b/src/py_commodity.cc
index 5aafa6c..c457e64 100644
--- a/src/py_commodity.cc
+++ b/src/py_commodity.cc
@@ -243,9 +243,6 @@ namespace {
void export_commodity()
{
-#if BOOST_VERSION >= 106000
- python::register_ptr_to_python< shared_ptr<commodity_pool_t> >();
-#endif
class_< commodity_pool_t, shared_ptr<commodity_pool_t>,
boost::noncopyable > ("CommodityPool", no_init)
.add_property("null_commodity",
diff --git a/src/py_journal.cc b/src/py_journal.cc
index c1c38a9..879f954 100644
--- a/src/py_journal.cc
+++ b/src/py_journal.cc
@@ -232,9 +232,6 @@ void export_journal()
boost::noncopyable >("PostHandler")
;
-#if BOOST_VERSION >= 106000
- python::register_ptr_to_python< shared_ptr<collector_wrapper> >();
-#endif
class_< collector_wrapper, shared_ptr<collector_wrapper>,
boost::noncopyable >("PostCollectorWrapper", no_init)
.def("__len__", &collector_wrapper::length)