20 lines
617 B
Diff
20 lines
617 B
Diff
Fix test failure on some 32-bit platforms.
|
|
|
|
Patch copied from upstream source repository:
|
|
|
|
https://github.com/curl/curl/commit/45a560390c4356bcb81d933bbbb229c8ea2acb63
|
|
|
|
diff --git a/src/tool_paramhlp.c b/src/tool_paramhlp.c
|
|
index b9dedc989e..85c5e79a7e 100644
|
|
--- a/src/tool_paramhlp.c
|
|
+++ b/src/tool_paramhlp.c
|
|
@@ -218,7 +218,7 @@ static ParameterError str2double(double *val, const char *str, long max)
|
|
num = strtod(str, &endptr);
|
|
if(errno == ERANGE)
|
|
return PARAM_NUMBER_TOO_LARGE;
|
|
- if((long)num > max) {
|
|
+ if(num > max) {
|
|
/* too large */
|
|
return PARAM_NUMBER_TOO_LARGE;
|
|
}
|