15 lines
481 B
Diff
15 lines
481 B
Diff
Taken from http://pkgs.fedoraproject.org/cgit/rpms/fcgi.git/plain/fcgi-2.4.0-gcc44_fixes.patch.
|
|
Fixes compilation with GCC 4.4 and later.
|
|
|
|
diff -up fcgi-2.4.0/libfcgi/fcgio.cpp.gcc44_fixes fcgi-2.4.0/libfcgi/fcgio.cpp
|
|
--- fcgi-2.4.0/libfcgi/fcgio.cpp.gcc44_fixes 2002-02-24 21:12:22.000000000 +0100
|
|
+++ fcgi-2.4.0/libfcgi/fcgio.cpp 2009-02-15 11:35:18.000000000 +0100
|
|
@@ -23,6 +23,7 @@
|
|
#endif
|
|
|
|
#include <limits.h>
|
|
+#include <cstdio>
|
|
#include "fcgio.h"
|
|
|
|
using std::streambuf;
|