29 lines
1.0 KiB
Diff
29 lines
1.0 KiB
Diff
This patch comes from http://hg.code.sf.net/p/graphicsmagick/code/rev/95d00d55e978.
|
|
|
|
diff -ur a/coders/sun.c b/coders/sun.c
|
|
--- a/coders/sun.c 2016-05-30 13:19:54.000000000 -0400
|
|
+++ b/coders/sun.c 2017-08-18 18:00:00.191023610 -0400
|
|
@@ -1,5 +1,5 @@
|
|
/*
|
|
-% Copyright (C) 2003-2015 GraphicsMagick Group
|
|
+% Copyright (C) 2003-2017 GraphicsMagick Group
|
|
% Copyright (C) 2002 ImageMagick Studio
|
|
% Copyright 1991-1999 E. I. du Pont de Nemours and Company
|
|
%
|
|
@@ -577,6 +577,7 @@
|
|
for (bit=7; bit >= 0; bit--)
|
|
{
|
|
index=((*p) & (0x01 << bit) ? 0x01 : 0x00);
|
|
+ VerifyColormapIndex(image,index);
|
|
indexes[x+7-bit]=index;
|
|
q[x+7-bit]=image->colormap[index];
|
|
}
|
|
@@ -587,6 +588,7 @@
|
|
for (bit=7; bit >= (long) (8-(image->columns % 8)); bit--)
|
|
{
|
|
index=((*p) & (0x01 << bit) ? 0x01 : 0x00);
|
|
+ VerifyColormapIndex(image,index);
|
|
indexes[x+7-bit]=index;
|
|
q[x+7-bit]=image->colormap[index];
|
|
}
|