41 lines
1.3 KiB
Diff
41 lines
1.3 KiB
Diff
Fix CVE-2017-7975:
|
|
|
|
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-7975
|
|
https://bugs.ghostscript.com/show_bug.cgi?id=697693
|
|
|
|
Patch copied from upstream source repository:
|
|
|
|
https://git.ghostscript.com/?p=jbig2dec.git;a=commit;h=f8992b8fe65c170c8624226f127c5c4bfed42c66
|
|
|
|
From f8992b8fe65c170c8624226f127c5c4bfed42c66 Mon Sep 17 00:00:00 2001
|
|
From: Shailesh Mistry <shailesh.mistry@hotmail.co.uk>
|
|
Date: Wed, 26 Apr 2017 22:12:14 +0100
|
|
Subject: [PATCH] Bug 697693: Prevent SEGV due to integer overflow.
|
|
|
|
While building a Huffman table, the start and end points were susceptible
|
|
to integer overflow.
|
|
|
|
Thank you to Jiaqi for finding this issue and suggesting a patch.
|
|
---
|
|
jbig2_huffman.c | 4 ++--
|
|
1 file changed, 2 insertions(+), 2 deletions(-)
|
|
|
|
diff --git a/jbig2_huffman.c b/jbig2_huffman.c
|
|
index 511e461..b4189a1 100644
|
|
--- a/jbig2_huffman.c
|
|
+++ b/jbig2_huffman.c
|
|
@@ -421,8 +421,8 @@ jbig2_build_huffman_table(Jbig2Ctx *ctx, const Jbig2HuffmanParams *params)
|
|
|
|
if (PREFLEN == CURLEN) {
|
|
int RANGELEN = lines[CURTEMP].RANGELEN;
|
|
- int start_j = CURCODE << shift;
|
|
- int end_j = (CURCODE + 1) << shift;
|
|
+ uint32_t start_j = CURCODE << shift;
|
|
+ uint32_t end_j = (CURCODE + 1) << shift;
|
|
byte eflags = 0;
|
|
|
|
if (end_j > max_j) {
|
|
--
|
|
2.13.0
|
|
|