42 lines
1.2 KiB
Diff
42 lines
1.2 KiB
Diff
Fixes compilation with Mesa >= 18.2.5.
|
|
|
|
Taken from upstream:
|
|
|
|
https://github.com/liballeg/allegro5/commit/a40d30e21802ecf5c9382cf34af9b01bd3781e47
|
|
|
|
diff --git a/include/allegro5/allegro_opengl.h b/include/allegro5/allegro_opengl.h
|
|
index 0f86a6768..652dd024e 100644
|
|
--- a/include/allegro5/allegro_opengl.h
|
|
+++ b/include/allegro5/allegro_opengl.h
|
|
@@ -103,10 +103,14 @@
|
|
|
|
/* HACK: Prevent both Mesa and SGI's broken headers from screwing us */
|
|
#define __glext_h_
|
|
+#define __gl_glext_h_
|
|
#define __glxext_h_
|
|
+#define __glx_glxext_h_
|
|
#include <GL/gl.h>
|
|
#undef __glext_h_
|
|
+#undef __gl_glext_h_
|
|
#undef __glxext_h_
|
|
+#undef __glx_glxext_h_
|
|
|
|
#endif /* ALLEGRO_MACOSX */
|
|
|
|
diff --git a/include/allegro5/opengl/GLext/glx_ext_defs.h b/include/allegro5/opengl/GLext/glx_ext_defs.h
|
|
index 49c502091..fba8aea5d 100644
|
|
--- a/include/allegro5/opengl/GLext/glx_ext_defs.h
|
|
+++ b/include/allegro5/opengl/GLext/glx_ext_defs.h
|
|
@@ -1,7 +1,9 @@
|
|
/* HACK: Prevent both Mesa and SGI's broken headers from screwing us */
|
|
#define __glxext_h_
|
|
+#define __glx_glxext_h_
|
|
#include <GL/glx.h>
|
|
#undef __glxext_h_
|
|
+#undef __glx_glxext_h_
|
|
|
|
#ifndef GLX_VERSION_1_3
|
|
#define _ALLEGRO_GLX_VERSION_1_3
|
|
--
|
|
2.20.0
|