53 lines
2.2 KiB
Diff
53 lines
2.2 KiB
Diff
Fix CVE-2016-9297:
|
|
|
|
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2016-9297
|
|
http://bugzilla.maptools.org/show_bug.cgi?id=2590
|
|
|
|
Patch copied from upstream source repository.
|
|
|
|
2016-11-11 Even Rouault <even.rouault at spatialys.com>
|
|
|
|
* libtiff/tif_dirread.c: in TIFFFetchNormalTag(), make sure that
|
|
values of tags with TIFF_SETGET_C16_ASCII / TIFF_SETGET_C32_ASCII
|
|
access are null terminated, to avoid potential read outside buffer
|
|
in _TIFFPrintField().
|
|
Fixes http://bugzilla.maptools.org/show_bug.cgi?id=2590
|
|
|
|
|
|
/cvs/maptools/cvsroot/libtiff/ChangeLog,v <-- ChangeLog
|
|
new revision: 1.1154; previous revision: 1.1153
|
|
/cvs/maptools/cvsroot/libtiff/libtiff/tif_dirread.c,v <--
|
|
libtiff/tif_dirread.c
|
|
new revision: 1.203; previous revision: 1.202Index: libtiff/libtiff/tif_dirread.c
|
|
===================================================================
|
|
RCS file: /cvs/maptools/cvsroot/libtiff/libtiff/tif_dirread.c,v
|
|
retrieving revision 1.202
|
|
retrieving revision 1.203
|
|
diff -u -r1.202 -r1.203
|
|
--- libtiff/libtiff/tif_dirread.c 11 Nov 2016 20:01:55 -0000 1.202
|
|
+++ libtiff/libtiff/tif_dirread.c 11 Nov 2016 20:22:01 -0000 1.203
|
|
@@ -5000,6 +5000,11 @@
|
|
if (err==TIFFReadDirEntryErrOk)
|
|
{
|
|
int m;
|
|
+ if( data[dp->tdir_count-1] != '\0' )
|
|
+ {
|
|
+ TIFFWarningExt(tif->tif_clientdata,module,"ASCII value for tag \"%s\" does not end in null byte. Forcing it to be null",fip->field_name);
|
|
+ data[dp->tdir_count-1] = '\0';
|
|
+ }
|
|
m=TIFFSetField(tif,dp->tdir_tag,(uint16)(dp->tdir_count),data);
|
|
if (data!=0)
|
|
_TIFFfree(data);
|
|
@@ -5172,6 +5177,11 @@
|
|
if (err==TIFFReadDirEntryErrOk)
|
|
{
|
|
int m;
|
|
+ if( data[dp->tdir_count-1] != '\0' )
|
|
+ {
|
|
+ TIFFWarningExt(tif->tif_clientdata,module,"ASCII value for tag \"%s\" does not end in null byte. Forcing it to be null",fip->field_name);
|
|
+ data[dp->tdir_count-1] = '\0';
|
|
+ }
|
|
m=TIFFSetField(tif,dp->tdir_tag,(uint32)(dp->tdir_count),data);
|
|
if (data!=0)
|
|
_TIFFfree(data);
|