31 lines
1.0 KiB
Diff
31 lines
1.0 KiB
Diff
Description: CVE-2014-0466: fixps does not invoke gs with -dSAFER
|
|
A malicious PostScript file could delete files with the privileges of
|
|
the invoking user.
|
|
Origin: vendor
|
|
Bug-Debian: http://bugs.debian.org/742902
|
|
Author: Salvatore Bonaccorso <carnil@debian.org>
|
|
Last-Update: 2014-03-28
|
|
|
|
--- a/contrib/fixps.in
|
|
+++ b/contrib/fixps.in
|
|
@@ -389,7 +389,7 @@
|
|
eval "$command" ;;
|
|
gs)
|
|
$verbose "$program: making a full rewrite of the file ($gs)." >&2
|
|
- $gs -q -dNOPAUSE -dBATCH -sDEVICE=pswrite -sOutputFile=- -c save pop -f $file ;;
|
|
+ $gs -q -dSAFER -dNOPAUSE -dBATCH -sDEVICE=pswrite -sOutputFile=- -c save pop -f $file ;;
|
|
esac
|
|
)
|
|
fi
|
|
--- a/contrib/fixps.m4
|
|
+++ b/contrib/fixps.m4
|
|
@@ -307,7 +307,7 @@
|
|
eval "$command" ;;
|
|
gs)
|
|
$verbose "$program: making a full rewrite of the file ($gs)." >&2
|
|
- $gs -q -dNOPAUSE -dBATCH -sDEVICE=pswrite -sOutputFile=- -c save pop -f $file ;;
|
|
+ $gs -q -dSAFER -dNOPAUSE -dBATCH -sDEVICE=pswrite -sOutputFile=- -c save pop -f $file ;;
|
|
esac
|
|
)
|
|
fi
|