45 lines
1.6 KiB
Diff
45 lines
1.6 KiB
Diff
Copied verbatim from upstream repository.
|
|
|
|
From cee22450ee30e79952f594796721dc6b17798ee6 Mon Sep 17 00:00:00 2001
|
|
From: Sascha Wilde <wilde@sha-bang.de>
|
|
Date: Fri, 23 Sep 2016 15:35:59 +0200
|
|
Subject: [PATCH] Removed unused lexical variables.
|
|
|
|
---
|
|
haskell-lexeme.el | 3 +--
|
|
haskell-process.el | 4 +---
|
|
2 files changed, 2 insertions(+), 5 deletions(-)
|
|
|
|
diff --git a/haskell-lexeme.el b/haskell-lexeme.el
|
|
index 4256a79..b832560 100644
|
|
--- a/haskell-lexeme.el
|
|
+++ b/haskell-lexeme.el
|
|
@@ -138,8 +138,7 @@ When match is successful, match-data will contain:
|
|
(match-text 2) - whole qualified identifier
|
|
(match-text 3) - unqualified part of identifier
|
|
(match-text 4) - closing backtick"
|
|
- (let ((begin (point))
|
|
- (match-data-old (match-data))
|
|
+ (let ((match-data-old (match-data))
|
|
first-backtick-start
|
|
last-backtick-start
|
|
qid-start
|
|
diff --git a/haskell-process.el b/haskell-process.el
|
|
index b4efba2..4f3f859 100644
|
|
--- a/haskell-process.el
|
|
+++ b/haskell-process.el
|
|
@@ -160,9 +160,7 @@ HPTYPE is the result of calling `'haskell-process-type`' function."
|
|
(defun haskell-process-log (msg)
|
|
"Effective append MSG to the process log (if enabled)."
|
|
(when haskell-process-log
|
|
- (let* ((append-to (get-buffer-create "*haskell-process-log*"))
|
|
- (windows (get-buffer-window-list append-to t t))
|
|
- move-point-in-windows)
|
|
+ (let* ((append-to (get-buffer-create "*haskell-process-log*")))
|
|
(with-current-buffer append-to
|
|
;; point should follow insertion so that it stays at the end
|
|
;; of the buffer
|
|
--
|
|
2.18.0
|
|
|