23 lines
808 B
Diff
23 lines
808 B
Diff
SIGINT is ignored in the Guix build environment.
|
|
|
|
--- a/Lib/test/test_regrtest.py
|
|
+++ b/Lib/test/test_regrtest.py
|
|
@@ -399,6 +399,8 @@
|
|
output = self.run_tests('--fromfile', filename)
|
|
self.check_executed_tests(output, tests)
|
|
|
|
+ @unittest.skipIf(True,
|
|
+ "KeyboardInterrupts do not work in the build environment")
|
|
def test_interrupted(self):
|
|
code = TEST_INTERRUPTED
|
|
test = self.create_test('sigint', code=code)
|
|
@@ -416,6 +418,8 @@
|
|
% (self.TESTNAME_REGEX, len(tests)))
|
|
self.check_line(output, regex)
|
|
|
|
+ @unittest.skipIf(True,
|
|
+ "KeyboardInterrupts do not work in the build environment")
|
|
def test_slow_interrupted(self):
|
|
# Issue #25373: test --slowest with an interrupted test
|
|
code = TEST_INTERRUPTED
|