20 lines
765 B
Diff
20 lines
765 B
Diff
Fix a deprecation warning with newer Perl that breaks some tests.
|
|
|
|
--- a/tp/Texinfo/Parser.pm
|
|
+++ b/tp/Texinfo/Parser.pm
|
|
@@ -5438,12 +5438,12 @@
|
|
}
|
|
} elsif ($command eq 'clickstyle') {
|
|
# REMACRO
|
|
- if ($line =~ /^\s+@([[:alnum:]][[:alnum:]\-]*)({})?\s*/) {
|
|
+ if ($line =~ /^\s+@([[:alnum:]][[:alnum:]\-]*)(\{})?\s*/) {
|
|
$args = ['@'.$1];
|
|
$self->{'clickstyle'} = $1
|
|
unless(_ignore_global_commands($self));
|
|
$remaining = $line;
|
|
- $remaining =~ s/^\s+@([[:alnum:]][[:alnum:]\-]*)({})?\s*(\@(c|comment)((\@|\s+).*)?)?//;
|
|
+ $remaining =~ s/^\s+@([[:alnum:]][[:alnum:]\-]*)(\{})?\s*(\@(c|comment)((\@|\s+).*)?)?//;
|
|
$has_comment = 1 if (defined($4));
|
|
} else {
|
|
$self->line_error (sprintf($self->__(
|