guix-devel/gnu/packages/patches/gobject-introspection-cc.patch

12 lines
466 B
Diff

Use gcc as the default C compiler if CC is not set.
--- gobject-introspection-1.44.0.orig/giscanner/__init__.py 2014-08-04 22:37:07.000000000 +0800
+++ gobject-introspection-1.44.0/giscanner/__init__.py 2015-04-20 17:30:26.507697234 +0800
@@ -22,3 +22,5 @@
builddir = os.environ.get('UNINSTALLED_INTROSPECTION_BUILDDIR')
if builddir is not None:
__path__.append(os.path.join(builddir, 'giscanner'))
+if not 'CC' in os.environ:
+ os.environ['CC'] = 'gcc'