guix-devel/gnu/packages/patches/acl-fix-perl-regex.patch

23 lines
515 B
Diff

This can be removed with the next acl release
---
test/run | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/test/run b/test/run
index 2cf52e8..4627cd2 100755
--- a/test/run
+++ b/test/run
@@ -70,7 +70,7 @@ for (;;) {
if (defined $line) {
# Substitute %VAR and %{VAR} with environment variables.
$line =~ s[%(\w+)][$ENV{$1}]eg;
- $line =~ s[%{(\w+)}][$ENV{$1}]eg;
+ $line =~ s[%\{(\w+)\}][$ENV{$1}]eg;
}
if (defined $line) {
if ($line =~ s/^\s*< ?//) {
--
2.15.0