guix-devel/gnu/packages/patches/tar-gets-undeclared.patch

27 lines
948 B
Diff

This patch is needed to allow builds with newer versions of
the GNU libc (2.16+).
This is a backport of this patch:
commit 66712c23388e93e5c518ebc8515140fa0c807348
Author: Eric Blake <eblake@redhat.com>
Date: Thu Mar 29 13:30:41 2012 -0600
stdio: don't assume gets any more
--- tar-1.26/gnu/stdio.in.h 2012-07-02 14:28:45.000000000 +0200
+++ tar-1.26/gnu/stdio.in.h 2012-07-02 14:28:50.000000000 +0200
@@ -160,12 +160,6 @@ _GL_WARN_ON_USE (fflush, "fflush is not
"use gnulib module fflush for portable POSIX compliance");
#endif
-/* It is very rare that the developer ever has full control of stdin,
- so any use of gets warrants an unconditional warning. Assume it is
- always declared, since it is required by C89. */
-#undef gets
-_GL_WARN_ON_USE (gets, "gets is a security hole - use fgets instead");
-
#if @GNULIB_FOPEN@
# if @REPLACE_FOPEN@
# if !(defined __cplusplus && defined GNULIB_NAMESPACE)