47 lines
1.2 KiB
Diff
47 lines
1.2 KiB
Diff
Fix CVE-2016-9017:
|
|
|
|
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2016-9107
|
|
http://bugs.ghostscript.com/show_bug.cgi?id=697171
|
|
|
|
Patch copied from upstream source repository:
|
|
http://git.ghostscript.com/?p=mujs.git;a=commitdiff;h=a5c747f1d40e8d6659a37a8d25f13fb5acf8e767
|
|
|
|
From a5c747f1d40e8d6659a37a8d25f13fb5acf8e767 Mon Sep 17 00:00:00 2001
|
|
From: Tor Andersson <tor.andersson@artifex.com>
|
|
Date: Tue, 25 Oct 2016 14:08:27 +0200
|
|
Subject: [PATCH] Fix 697171: missed an operand in the bytecode debugger dump.
|
|
|
|
---
|
|
jscompile.h | 2 +-
|
|
jsdump.c | 1 +
|
|
2 files changed, 2 insertions(+), 1 deletion(-)
|
|
|
|
diff --git a/jscompile.h b/jscompile.h
|
|
index 802cc9e..3054d13 100644
|
|
--- a/thirdparty/mujs/jscompile.h
|
|
+++ b/thirdparty/mujs/jscompile.h
|
|
@@ -21,7 +21,7 @@ enum js_OpCode
|
|
|
|
OP_NEWARRAY,
|
|
OP_NEWOBJECT,
|
|
- OP_NEWREGEXP,
|
|
+ OP_NEWREGEXP, /* -S,opts- <regexp> */
|
|
|
|
OP_UNDEF,
|
|
OP_NULL,
|
|
diff --git a/jsdump.c b/jsdump.c
|
|
index 1c51c29..37ad88c 100644
|
|
--- a/thirdparty/mujs/jsdump.c
|
|
+++ b/thirdparty/mujs/jsdump.c
|
|
@@ -750,6 +750,7 @@ void jsC_dumpfunction(js_State *J, js_Function *F)
|
|
case OP_INITVAR:
|
|
case OP_DEFVAR:
|
|
case OP_GETVAR:
|
|
+ case OP_HASVAR:
|
|
case OP_SETVAR:
|
|
case OP_DELVAR:
|
|
case OP_GETPROP_S:
|
|
--
|
|
2.10.2
|
|
|