34 lines
1.5 KiB
Diff
34 lines
1.5 KiB
Diff
From 28b6204b1421aa57b3c10c43d90cb516910bc80f Mon Sep 17 00:00:00 2001
|
|
From: Markus Stange <mstange@themasta.com>
|
|
Date: Tue, 6 Jan 2015 12:08:39 +0100
|
|
Subject: [PATCH] Bug 1117304 - Also do the checks at the start of CopyRect in
|
|
release builds. r=Bas, a=sledru
|
|
|
|
---
|
|
gfx/2d/FilterNodeSoftware.cpp | 9 ++++++---
|
|
1 file changed, 6 insertions(+), 3 deletions(-)
|
|
|
|
diff --git a/gfx/2d/FilterNodeSoftware.cpp b/gfx/2d/FilterNodeSoftware.cpp
|
|
index 00d790f..396d0da 100644
|
|
--- a/gfx/2d/FilterNodeSoftware.cpp
|
|
+++ b/gfx/2d/FilterNodeSoftware.cpp
|
|
@@ -253,9 +253,12 @@ CopyRect(DataSourceSurface* aSrc, DataSourceSurface* aDest,
|
|
MOZ_CRASH("we should never be getting invalid rects at this point");
|
|
}
|
|
|
|
- MOZ_ASSERT(aSrc->GetFormat() == aDest->GetFormat(), "different surface formats");
|
|
- MOZ_ASSERT(IntRect(IntPoint(), aSrc->GetSize()).Contains(aSrcRect), "source rect too big for source surface");
|
|
- MOZ_ASSERT(IntRect(IntPoint(), aDest->GetSize()).Contains(aSrcRect - aSrcRect.TopLeft() + aDestPoint), "dest surface too small");
|
|
+ MOZ_RELEASE_ASSERT(aSrc->GetFormat() == aDest->GetFormat(),
|
|
+ "different surface formats");
|
|
+ MOZ_RELEASE_ASSERT(IntRect(IntPoint(), aSrc->GetSize()).Contains(aSrcRect),
|
|
+ "source rect too big for source surface");
|
|
+ MOZ_RELEASE_ASSERT(IntRect(IntPoint(), aDest->GetSize()).Contains(IntRect(aDestPoint, aSrcRect.Size())),
|
|
+ "dest surface too small");
|
|
|
|
if (aSrcRect.IsEmpty()) {
|
|
return;
|
|
--
|
|
2.2.1
|
|
|