33 lines
1.2 KiB
Diff
33 lines
1.2 KiB
Diff
From c8437505a63fc2b2552b8af217d60d79abb92ba3 Mon Sep 17 00:00:00 2001
|
|
From: Ben Turner <bent.mozilla@gmail.com>
|
|
Date: Fri, 6 Feb 2015 15:25:33 -0800
|
|
Subject: [PATCH] Bug 1130541. r=janv, a=sledru
|
|
|
|
---
|
|
dom/indexedDB/IDBDatabase.cpp | 2 ++
|
|
1 file changed, 2 insertions(+)
|
|
|
|
diff --git a/dom/indexedDB/IDBDatabase.cpp b/dom/indexedDB/IDBDatabase.cpp
|
|
index 7329cec..c9c7e4f 100644
|
|
--- a/dom/indexedDB/IDBDatabase.cpp
|
|
+++ b/dom/indexedDB/IDBDatabase.cpp
|
|
@@ -536,6 +536,7 @@ IDBDatabase::CreateObjectStore(
|
|
IDBTransaction* transaction = AsyncConnectionHelper::GetCurrentTransaction();
|
|
|
|
if (!transaction ||
|
|
+ transaction->Database() != this ||
|
|
transaction->GetMode() != IDBTransaction::VERSION_CHANGE) {
|
|
aRv.Throw(NS_ERROR_DOM_INDEXEDDB_NOT_ALLOWED_ERR);
|
|
return nullptr;
|
|
@@ -577,6 +578,7 @@ IDBDatabase::DeleteObjectStore(const nsAString& aName, ErrorResult& aRv)
|
|
IDBTransaction* transaction = AsyncConnectionHelper::GetCurrentTransaction();
|
|
|
|
if (!transaction ||
|
|
+ transaction->Database() != this ||
|
|
transaction->GetMode() != IDBTransaction::VERSION_CHANGE) {
|
|
aRv.Throw(NS_ERROR_DOM_INDEXEDDB_NOT_ALLOWED_ERR);
|
|
return;
|
|
--
|
|
2.2.1
|
|
|