26 lines
842 B
Diff
26 lines
842 B
Diff
From 746ddf19ff532b8abc90d3a91322a04b462ebfa8 Mon Sep 17 00:00:00 2001
|
|
From: Brian Hackett <bhackett1024@gmail.com>
|
|
Date: Mon, 26 Jan 2015 13:14:34 -0500
|
|
Subject: [PATCH] Bug 1124018 - Null the allocation site table if
|
|
initialization fails. r=jonco, a=bkerensa
|
|
|
|
---
|
|
js/src/jsinfer.cpp | 1 +
|
|
1 file changed, 1 insertion(+)
|
|
|
|
diff --git a/js/src/jsinfer.cpp b/js/src/jsinfer.cpp
|
|
index b62ad1f..4019b16 100644
|
|
--- a/js/src/jsinfer.cpp
|
|
+++ b/js/src/jsinfer.cpp
|
|
@@ -2035,6 +2035,7 @@ TypeCompartment::addAllocationSiteTypeObject(JSContext *cx, AllocationSiteKey ke
|
|
allocationSiteTable = cx->new_<AllocationSiteTable>();
|
|
if (!allocationSiteTable || !allocationSiteTable->init()) {
|
|
js_delete(allocationSiteTable);
|
|
+ allocationSiteTable = nullptr;
|
|
return nullptr;
|
|
}
|
|
}
|
|
--
|
|
2.2.1
|
|
|