36 lines
1.2 KiB
Diff
36 lines
1.2 KiB
Diff
From 147543038273042f71284fa8487c71670163da5f Mon Sep 17 00:00:00 2001
|
|
From: Ralph Giles <giles@mozilla.com>
|
|
Date: Tue, 31 Mar 2015 16:18:22 -0700
|
|
Subject: [PATCH] Bug 1080995 - Don't use the h264parser gstreamer element.
|
|
r=kinetik, a=sledru
|
|
|
|
---
|
|
content/media/gstreamer/GStreamerFormatHelper.cpp | 4 +++-
|
|
1 file changed, 3 insertions(+), 1 deletion(-)
|
|
|
|
diff --git a/content/media/gstreamer/GStreamerFormatHelper.cpp b/content/media/gstreamer/GStreamerFormatHelper.cpp
|
|
index 25095e7..ebd12c2 100644
|
|
--- a/content/media/gstreamer/GStreamerFormatHelper.cpp
|
|
+++ b/content/media/gstreamer/GStreamerFormatHelper.cpp
|
|
@@ -67,6 +67,7 @@ static char const * const sDefaultCodecCaps[][2] = {
|
|
|
|
static char const * const sPluginBlacklist[] = {
|
|
"flump3dec",
|
|
+ "h264parse",
|
|
};
|
|
|
|
GStreamerFormatHelper::GStreamerFormatHelper()
|
|
@@ -251,7 +252,8 @@ static gboolean FactoryFilter(GstPluginFeature *aFeature, gpointer)
|
|
const gchar *className =
|
|
gst_element_factory_get_klass(GST_ELEMENT_FACTORY_CAST(aFeature));
|
|
|
|
- if (!strstr(className, "Decoder") && !strstr(className, "Demux")) {
|
|
+ if (!strstr(className, "Decoder") && !strstr(className, "Demux") &&
|
|
+ !strstr(className, "Parser")) {
|
|
return FALSE;
|
|
}
|
|
|
|
--
|
|
2.2.1
|
|
|