51 lines
2.1 KiB
Diff
51 lines
2.1 KiB
Diff
From 2cda46e6158a459b56b392c8e389b055fdf740ca Mon Sep 17 00:00:00 2001
|
|
From: Ryan VanderMeulen <ryanvm@gmail.com>
|
|
Date: Mon, 6 Apr 2015 22:59:41 -0400
|
|
Subject: [PATCH] Bug 1149542 - Replace MOZ_ASSERT_UNREACHABLE with MOZ_ASSERT.
|
|
r=dholbert, a=bustage
|
|
|
|
---
|
|
layout/svg/SVGTextFrame.cpp | 12 ++++++------
|
|
1 file changed, 6 insertions(+), 6 deletions(-)
|
|
|
|
diff --git a/layout/svg/SVGTextFrame.cpp b/layout/svg/SVGTextFrame.cpp
|
|
index 9d331b8..e7b7275 100644
|
|
--- a/layout/svg/SVGTextFrame.cpp
|
|
+++ b/layout/svg/SVGTextFrame.cpp
|
|
@@ -4333,8 +4333,8 @@ SVGTextFrame::ResolvePositionsForNode(nsIContent* aContent,
|
|
if (length) {
|
|
uint32_t end = aIndex + length;
|
|
if (MOZ_UNLIKELY(end > mPositions.Length())) {
|
|
- MOZ_ASSERT_UNREACHABLE("length of mPositions does not match characters "
|
|
- "found by iterating content");
|
|
+ MOZ_ASSERT(false, "length of mPositions does not match characters "
|
|
+ "found by iterating content");
|
|
return false;
|
|
}
|
|
if (aForceStartOfChunk) {
|
|
@@ -4367,8 +4367,8 @@ SVGTextFrame::ResolvePositionsForNode(nsIContent* aContent,
|
|
// only if they actually have some text content.
|
|
if (HasTextContent(aContent)) {
|
|
if (MOZ_UNLIKELY(aIndex >= mPositions.Length())) {
|
|
- MOZ_ASSERT_UNREACHABLE("length of mPositions does not match characters "
|
|
- "found by iterating content");
|
|
+ MOZ_ASSERT(false, "length of mPositions does not match characters "
|
|
+ "found by iterating content");
|
|
return false;
|
|
}
|
|
mPositions[aIndex].mPosition = gfxPoint();
|
|
@@ -4394,8 +4394,8 @@ SVGTextFrame::ResolvePositionsForNode(nsIContent* aContent,
|
|
uint32_t count = GetTextContentLength(aContent);
|
|
|
|
if (MOZ_UNLIKELY(aIndex + count > mPositions.Length())) {
|
|
- MOZ_ASSERT_UNREACHABLE("length of mPositions does not match characters "
|
|
- "found by iterating content");
|
|
+ MOZ_ASSERT(false, "length of mPositions does not match characters "
|
|
+ "found by iterating content");
|
|
return false;
|
|
}
|
|
|
|
--
|
|
2.2.1
|
|
|