50 lines
1.7 KiB
Diff
50 lines
1.7 KiB
Diff
Use upstream utf8proc package, as suggested in
|
|
http://source.netsurf-browser.org/libutf8proc.git/commit/?id=770e329cceaf0620c7b482589a9b17ed1d19c16d
|
|
|
|
Work around upstream's lack of a pkg-config file and update API.
|
|
|
|
--- netsurf-3.6/Makefile
|
|
+++ netsurf-3.6/Makefile
|
|
@@ -527,10 +527,9 @@
|
|
$(eval $(call pkg_config_find_and_add,libcss,CSS))
|
|
$(eval $(call pkg_config_find_and_add,libdom,DOM))
|
|
$(eval $(call pkg_config_find_and_add,libnsutils,nsutils))
|
|
-$(eval $(call pkg_config_find_and_add,libutf8proc,utf8proc))
|
|
|
|
# Common libraries without pkg-config support
|
|
-LDFLAGS += -lz
|
|
+LDFLAGS += -lz -lutf8proc
|
|
|
|
# Optional libraries with pkgconfig
|
|
|
|
--- netsurf-3.6/utils/idna.c
|
|
+++ netsurf-3.6/utils/idna.c
|
|
@@ -26,7 +26,7 @@
|
|
#include <stdint.h>
|
|
#include <stdlib.h>
|
|
#include <string.h>
|
|
-#include <libutf8proc/utf8proc.h>
|
|
+#include <utf8proc.h>
|
|
|
|
#include "utils/errors.h"
|
|
#include "utils/idna.h"
|
|
--- netsurf-3.7/test/Makefile 2017-10-15 08:39:24.000000000 -0500
|
|
+++ netsurf-3.7/test/Makefile 2017-11-05 11:14:46.219013218 -0600
|
|
@@ -139,14 +139,14 @@
|
|
-D_XOPEN_SOURCE=600 \
|
|
-Itest -Iinclude -Icontent/handlers -Ifrontends -I. -I.. \
|
|
-Dnsgtk \
|
|
- $(shell pkg-config --cflags libcurl libparserutils libwapcaplet libdom libnsutils libutf8proc) \
|
|
+ $(shell pkg-config --cflags libcurl libparserutils libwapcaplet libdom libnsutils) \
|
|
$(LIB_CFLAGS)
|
|
TESTCFLAGS := $(BASE_TESTCFLAGS) \
|
|
$(COV_CFLAGS) \
|
|
$(COV_CPPFLAGS)
|
|
|
|
TESTLDFLAGS := -L$(TESTROOT) \
|
|
- $(shell pkg-config --libs libcurl libparserutils libwapcaplet libdom libnsutils libutf8proc) -lz \
|
|
+ $(shell pkg-config --libs libcurl libparserutils libwapcaplet libdom libnsutils) -lz -lutf8proc \
|
|
$(LIB_LDFLAGS)\
|
|
$(COV_LDFLAGS)
|
|
|