29 lines
915 B
Diff
29 lines
915 B
Diff
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
|
index 2efc649..8903b52 100644
|
|
--- a/CMakeLists.txt
|
|
+++ b/CMakeLists.txt
|
|
@@ -93,7 +95,7 @@
|
|
find_package(XKB REQUIRED)
|
|
|
|
# Qt 5
|
|
-find_package(Qt5 5.6.0 CONFIG REQUIRED Core DBus Gui Qml Quick LinguistTools)
|
|
+find_package(Qt5 5.8.0 CONFIG REQUIRED Core DBus Gui Qml Quick LinguistTools Test)
|
|
|
|
# find qt5 imports dir
|
|
get_target_property(QMAKE_EXECUTABLE Qt5::qmake LOCATION)
|
|
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
|
|
index c9d935a..bb85ddd 100644
|
|
--- a/test/CMakeLists.txt
|
|
+++ b/test/CMakeLists.txt
|
|
@@ -2,9 +2,8 @@
|
|
|
|
include_directories(../src/common)
|
|
|
|
-
|
|
set(ConfigurationTest_SRCS ConfigurationTest.cpp ../src/common/ConfigReader.cpp)
|
|
add_executable(ConfigurationTest ${ConfigurationTest_SRCS})
|
|
add_test(NAME Configuration COMMAND ConfigurationTest)
|
|
|
|
-qt5_use_modules(ConfigurationTest Test)
|
|
+target_link_libraries(ConfigurationTest Qt5::Core Qt5::Test)
|