guix-devel/gnu/packages/patches/python-cython-fix-tests-32b...

28 lines
827 B
Diff

This fixes a test failure on 32-bit platforms.
Upstream bug URL: https://github.com/cython/cython/issues/1548
Patch copied from upstream source repository:
https://github.com/cython/cython/commit/d92a718a26c9354fbf35f31a17de5c069865a447
From d92a718a26c9354fbf35f31a17de5c069865a447 Mon Sep 17 00:00:00 2001
From: Robert Bradshaw <robertwb@gmail.com>
Date: Tue, 24 Jan 2017 16:57:00 -0800
Subject: [PATCH] Normalize possible L suffix.
---
tests/run/cpdef_enums.pyx | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/tests/run/cpdef_enums.pyx b/tests/run/cpdef_enums.pyx
index 167c762..c264ec5 100644
--- a/tests/run/cpdef_enums.pyx
+++ b/tests/run/cpdef_enums.pyx
@@ -93,4 +93,4 @@ def verify_resolution_GH1533():
3
"""
THREE = 100
- return PyxEnum.THREE
+ return int(PyxEnum.THREE)