28 lines
977 B
Diff
28 lines
977 B
Diff
This patch fixes the issue described at
|
|
https://bitbucket.org/berkeleylab/metabat/issues/28/compilation-fail-with-boost-164
|
|
|
|
diff --git a/src/metabat.h b/src/metabat.h
|
|
index 32ae94c..2292c04 100644
|
|
--- a/src/metabat.h
|
|
+++ b/src/metabat.h
|
|
@@ -35,6 +35,7 @@ KSEQ_INIT(gzFile, gzread)
|
|
|
|
#include <boost/program_options.hpp>
|
|
#include <boost/algorithm/string.hpp>
|
|
+#include <boost/serialization/array_wrapper.hpp>
|
|
#include <boost/numeric/ublas/matrix.hpp>
|
|
#include <boost/math/distributions.hpp>
|
|
#include <boost/serialization/serialization.hpp>
|
|
diff --git a/src/metabat2.h b/src/metabat2.h
|
|
index 60a9998..19fa815 100644
|
|
--- a/src/metabat2.h
|
|
+++ b/src/metabat2.h
|
|
@@ -41,6 +41,7 @@ KSEQ_INIT(gzFile, gzread)
|
|
|
|
#include <boost/program_options.hpp>
|
|
#include <boost/algorithm/string.hpp>
|
|
+#include <boost/serialization/array_wrapper.hpp>
|
|
#include <boost/numeric/ublas/matrix.hpp>
|
|
#include <boost/numeric/ublas/matrix_sparse.hpp>
|
|
#include <boost/numeric/ublas/matrix_proxy.hpp>
|