guix-devel/gnu/packages/patches/qt5-runpath.patch

26 lines
1.2 KiB
Diff

Allow the use of DT_RUNPATH. This fixes a bug whereby libQt5WebEngineCore.so
ends up having an empty RUNPATH.
--- qt-everywhere-opensource-src-5.4.1/qtwebengine/src/3rdparty/chromium/build/common.gypi 2015-04-14 10:21:09.330925545 +0200
+++ qt-everywhere-opensource-src-5.4.1/qtwebengine/src/3rdparty/chromium/build/common.gypi 2015-04-14 10:21:38.735106097 +0200
@@ -4142,19 +4142,6 @@
'-B<!(cd <(DEPTH) && pwd -P)/<(binutils_dir)',
],
}],
- # Some binutils 2.23 releases may or may not have new dtags enabled,
- # but they are all compatible with --disable-new-dtags,
- # because the new dynamic tags are not created by default.
- ['binutils_version>=223', {
- # Newer binutils don't set DT_RPATH unless you disable "new" dtags
- # and the new DT_RUNPATH doesn't work without --no-as-needed flag.
- # FIXME(mithro): Figure out the --as-needed/--no-as-needed flags
- # inside this file to allow usage of --no-as-needed and removal of
- # this flag.
- 'ldflags': [
- '-Wl,--disable-new-dtags',
- ],
- }]
],
},
}],