48 lines
1.2 KiB
Diff
48 lines
1.2 KiB
Diff
Honor SOURCE_DATE_EPOCH when exporting configuration date.
|
|
Autoconf-level patch submitted upstream on Fri Apr 15 23:07:42 UTC 2016
|
|
|
|
--- a/configure
|
|
+++ b/configure
|
|
@@ -2866,7 +2866,17 @@
|
|
|
|
|
|
# Configuration Date
|
|
- CONFIG_DATE="`date`"
|
|
+ CONFIG_DATE="`date -u`"
|
|
+if test -n "$SOURCE_DATE_EPOCH"; then
|
|
+ CONFIG_DATE=`date -u -d "@$SOURCE_DATE_EPOCH" 2>/dev/null \
|
|
+ || date -u -r "$SOURCE_DATE_EPOCH" 2>/dev/null`
|
|
+ if test -z "$CONFIG_DATE"; then
|
|
+ as_fn_error $? "malformed SOURCE_DATE_EPOCH" "$LINENO" 5
|
|
+ fi
|
|
+fi
|
|
+cat >>confdefs.h <<_ACEOF
|
|
+#define CONFIG_DATE "$CONFIG_DATE"
|
|
+_ACEOF
|
|
|
|
# Find out about the host we're building on.
|
|
ac_aux_dir=
|
|
--- a/libdispatch/derror.c
|
|
+++ b/libdispatch/derror.c
|
|
@@ -13,7 +13,7 @@
|
|
#endif
|
|
|
|
/* Tell the user the version of netCDF. */
|
|
-static const char nc_libvers[] = PACKAGE_VERSION " of "__DATE__" "__TIME__" $";
|
|
+static const char nc_libvers[] = PACKAGE_VERSION " of "CONFIG_DATE" $";
|
|
|
|
/**
|
|
\defgroup lib_version Library Version
|
|
--- a/config.h.in
|
|
+++ b/config.h.in
|
|
@@ -393,6 +393,9 @@
|
|
/* Define to the version of this package. */
|
|
#undef PACKAGE_VERSION
|
|
|
|
+/* Define to the configuration date */
|
|
+#undef CONFIG_DATE
|
|
+
|
|
/* The size of `double', as computed by sizeof. */
|
|
#undef SIZEOF_DOUBLE
|
|
|